re = /\b[^.,]+\./
str = 'item.i_item_sk,item.i_item_id,item.i_rec_start_date,item.i_rec_end_date'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end