using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=www.)[\w\.\/]+|(?<=http:\/\/)[\w\.\/]+|\w+.com\/\w+|\w+.net\/\w+";
string input = @" www.example.com/directory
http://example.com/directory
example.com/directory
example.net/directory
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}