$re = '/(?<=www.)[\w\.\/]+|(?<=http:\/\/)[\w\.\/]+|\w+.com\/\w+|\w+.net\/\w+/m';
$str = ' www.example.com/directory
http://example.com/directory
example.com/directory
example.net/directory
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);