re = /(?<=www.)[\w\.\/]+|(?<=http:\/\/)[\w\.\/]+|\w+.com\/\w+|\w+.net\/\w+/m
str = ' www.example.com/directory
http://example.com/directory
example.com/directory
example.net/directory
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end