using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\w#+]+";
string input = @"erp qwERPa ERP
ERP myERP erp,c++ C+ C# Powerpoint;C++;
not,ERP, /ERP/ :ERP,(erp6)
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}