package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)[\w#+]+`)
var str = `erp qwERPa ERP
ERP myERP erp,c++ C+ C# Powerpoint;C++;
not,ERP, /ERP/ :ERP,(erp6)
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}