re = /[\w#+]+/i
str = 'erp qwERPa ERP
ERP myERP erp,c++ C+ C# Powerpoint;C++;
not,ERP, /ERP/ :ERP,(erp6)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end