const regex = /^(?=.{194}\\2\\.\)\{2}\.\{12}\$\/D$)((?=(.2.|))\2\/\2\^\2\(\2\?=\2\.\2\{194}\2\\\2\\2\2\\\2\\\2\.\2\\\2\)\2\\\2\{2}\2\\\2\.\2\\\2\{12}\2\\\2\$\2\\\2\/D\2\$\2\)\2\(\2\(\2\?=\2\(\2\.2\2\.\2\|\2\)\2\)){2}.{12}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.{194}\\\\2\\\\.\\)\\{2}\\.\\{12}\\$\\\/D$)((?=(.2.|))\\2\\\/\\2\\^\\2\\(\\2\\?=\\2\\.\\2\\{194}\\2\\\\\\2\\\\2\\2\\\\\\2\\\\\\2\\.\\2\\\\\\2\\)\\2\\\\\\2\\{2}\\2\\\\\\2\\.\\2\\\\\\2\\{12}\\2\\\\\\2\\$\\2\\\\\\2\\\/D\\2\\$\\2\\)\\2\\(\\2\\(\\2\\?=\\2\\(\\2\\.2\\2\\.\\2\\|\\2\\)\\2\\)){2}.{12}$', '')
const str = `/^(?=.{194}\\\\2\\\\.\\)\\{2}\\.\\{12}\\\$\\/D\$)((?=(.2.|))\\2\\/\\2\\^\\2\\(\\2\\?=\\2\\.\\2\\{194}\\2\\\\\\2\\\\2\\2\\\\\\2\\\\\\2\\.\\2\\\\\\2\\)\\2\\\\\\2\\{2}\\2\\\\\\2\\.\\2\\\\\\2\\{12}\\2\\\\\\2\\\$\\2\\\\\\2\\/D\\2\\\$\\2\\)\\2\\(\\2\\(\\2\\?=\\2\\(\\2\\.2\\2\\.\\2\\|\\2\\)\\2\\)){2}.{12}\$/D`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}