re = /^(?=.{194}\\2\\.\)\{2}\.\{12}\$\/D$)((?=(.2.|))\2\/\2\^\2\(\2\?=\2\.\2\{194}\2\\\2\\2\2\\\2\\\2\.\2\\\2\)\2\\\2\{2}\2\\\2\.\2\\\2\{12}\2\\\2\$\2\\\2\/D\2\$\2\)\2\(\2\(\2\?=\2\(\2\.2\2\.\2\|\2\)\2\)){2}.{12}$/
str = '/^(?=.{194}\\\\2\\\\.\\)\\{2}\\.\\{12}\\$\\/D$)((?=(.2.|))\\2\\/\\2\\^\\2\\(\\2\\?=\\2\\.\\2\\{194}\\2\\\\\\2\\\\2\\2\\\\\\2\\\\\\2\\.\\2\\\\\\2\\)\\2\\\\\\2\\{2}\\2\\\\\\2\\.\\2\\\\\\2\\{12}\\2\\\\\\2\\$\\2\\\\\\2\\/D\\2\\$\\2\\)\\2\\(\\2\\(\\2\\?=\\2\\(\\2\\.2\\2\\.\\2\\|\\2\\)\\2\\)){2}.{12}$/D'
# Print the match result
str.match(re) do |match|
puts match.to_s
end