$re = '/^(?=.{194}\\\\2\\\\.\)\{2}\.\{12}\$\/D$)((?=(.2.|))\2\/\2\^\2\(\2\?=\2\.\2\{194}\2\\\\\2\\\\2\2\\\\\2\\\\\2\.\2\\\\\2\)\2\\\\\2\{2}\2\\\\\2\.\2\\\\\2\{12}\2\\\\\2\$\2\\\\\2\/D\2\$\2\)\2\(\2\(\2\?=\2\(\2\.2\2\.\2\|\2\)\2\)){2}.{12}$/D';
$str = '/^(?=.{194}\\\\2\\\\.\\)\\{2}\\.\\{12}\\$\\/D$)((?=(.2.|))\\2\\/\\2\\^\\2\\(\\2\\?=\\2\\.\\2\\{194}\\2\\\\\\2\\\\2\\2\\\\\\2\\\\\\2\\.\\2\\\\\\2\\)\\2\\\\\\2\\{2}\\2\\\\\\2\\.\\2\\\\\\2\\{12}\\2\\\\\\2\\$\\2\\\\\\2\\/D\\2\\$\\2\\)\\2\\(\\2\\(\\2\\?=\\2\\(\\2\\.2\\2\\.\\2\\|\\2\\)\\2\\)){2}.{12}$/D';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);