using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!.)[a-zA-Z]+[\d]+[a-zA-Z]+[-\w]*";
string input = @"test02a-d.test.example.net
test02b-d.test.example.net
test03a.test.example.net
test03b.test.example.net
test04-d.test.example.net
test05.test.example.net
test01.test90a-d.example.net";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}