re = /(?<!.)[a-zA-Z]+[\d]+[a-zA-Z]+[-\w]*/
str = 'test02a-d.test.example.net
test02b-d.test.example.net
test03a.test.example.net
test03b.test.example.net
test04-d.test.example.net
test05.test.example.net
test01.test90a-d.example.net'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end