import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!.)[a-zA-Z]+[\\d]+[a-zA-Z]+[-\\w]*";
final String string = "test02a-d.test.example.net\n"
+ "test02b-d.test.example.net\n"
+ "test03a.test.example.net\n"
+ "test03b.test.example.net\n"
+ "test04-d.test.example.net\n"
+ "test05.test.example.net\n"
+ "test01.test90a-d.example.net";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}