#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[a-z0-9.-_]+[^A-Z]@[a-z0-9.-]{2,}[.]{1}[a-z]{2,}"
Local $sString = "Abc@gmail.com"
Local $sSubst = "SQ"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)