using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[a-z0-9.-_]+[^A-Z]@[a-z0-9.-]{2,}[.]{1}[a-z]{2,}";
string substitution = @"SQ";
string input = @"Abc@gmail.com";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}