package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[a-z0-9.-_]+[^A-Z]@[a-z0-9.-]{2,}[.]{1}[a-z]{2,}`)
var str = []byte(`Abc@gmail.com`)
var substitution = []byte("SQ")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}