const regex = /#(<a[a-z\-_\s\"\#\=]*)(href=")((https?|http):\/\/)#i/ism;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('#(<a[a-z\\-_\\s\\"\\#\\=]*)(href=")((https?|http):\\\/\\\/)#i', 'ism')
const str = `<a href="url">vasya</a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}