re = /#(<a[a-z\-_\s\"\#\=]*)(href=")((https?|http):\/\/)#i/im
str = '<a href="url">vasya</a>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end