$re = '/#(<a[a-z\-_\s\"\#\=]*)(href=")((https?|http):\/\/)#i/ismU';
$str = '<a href="url">vasya</a>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);