import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^|\\s|>)<Project\\s(([^>]*?)\\s)?Sdk(\\s*?)=(\\s*?)\"";
final String string = "<Project Sdk=\"Microsoft.NET.Sdk\">\n\n"
+ " <!-- Whatever -->\n\n"
+ "</Project>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}