$re = '/(^|\s|>)<Project\s(([^>]*?)\s)?Sdk(\s*?)=(\s*?)"/is';
$str = '<Project Sdk="Microsoft.NET.Sdk">
<!-- Whatever -->
</Project>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);