re = /(^|\s|>)<Project\s(([^>]*?)\s)?Sdk(\s*?)=(\s*?)"/i
str = '<Project Sdk="Microsoft.NET.Sdk">
<!-- Whatever -->
</Project>'
# Print the match result
str.match(re) do |match|
puts match.to_s
end