package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bterm|term\b|\bterm\b`)
var str = `a term is <-- yes, space before and space after (two boundaries)
the terms are <-- yes, space before (one boundary)
the midterm was <-- yes, space after (one boundary)
the midterms were`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}