re = /\bterm|term\b|\bterm\b/m
str = 'a term is <-- yes, space before and space after (two boundaries)
the terms are <-- yes, space before (one boundary)
the midterm was <-- yes, space after (one boundary)
the midterms were'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end