import re
regex = re.compile(r"\bterm|term\b|\bterm\b", flags=re.MULTILINE)
test_str = ("a term is <-- yes, space before and space after (two boundaries)\n"
"the terms are <-- yes, space before (one boundary)\n"
"the midterm was <-- yes, space after (one boundary)\n"
"the midterms were")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")