#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ux)\b" & @CRLF & _
"(?=" & @CRLF & _
" (?<result>" & @CRLF & _
" (?<consume>" & @CRLF & _
" (?> \w+ \h+ ){0,3}?" & @CRLF & _
" keyword \b" & @CRLF & _
" )" & @CRLF & _
" (?: \h+ (?! keyword \b ) \w+ ){0,3}" & @CRLF & _
" )" & @CRLF & _
") \g{consume}" & @CRLF & _
""
Local $sString = "word1 word2 word3 keyword word4 word5 word6 keyword word7 word8 word9 word10" & @CRLF & _
"word2 keyword word4 word5 word6 keyword word7 word8" & @CRLF & _
"word2 word3 keyword word4 word5 word6 keyword word7 keyword word10"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")