package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b
(?=
(?<result>
(?<consume>
(?> \w+ \h+ ){0,3}?
keyword \b
)
(?: \h+ (?! keyword \b ) \w+ ){0,3}
)
) \g{consume}
`)
var str = `word1 word2 word3 keyword word4 word5 word6 keyword word7 word8 word9 word10
word2 keyword word4 word5 word6 keyword word7 word8
word2 word3 keyword word4 word5 word6 keyword word7 keyword word10`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}