using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b
(?=
(?<result>
(?<consume>
(?> \w+ \h+ ){0,3}?
keyword \b
)
(?: \h+ (?! keyword \b ) \w+ ){0,3}
)
) \g{consume}
";
string input = @"word1 word2 word3 keyword word4 word5 word6 keyword word7 word8 word9 word10
word2 keyword word4 word5 word6 keyword word7 word8
word2 word3 keyword word4 word5 word6 keyword word7 keyword word10";
RegexOptions options = RegexOptions.CultureInvariant | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}