#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)(?:^| )@[^@\s]+(?!.*?\s@\w+.*$)"
Local $sString = "hello hi @why helo @blow but @name" & @CRLF & _
"" & @CRLF & _
"hello hi @why helo @blow but name@name" & @CRLF & _
"" & @CRLF & _
"@blow but not know how to resolve this"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")