using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^| )@[^@\s]+(?!.*?\s@\w+.*$)";
string input = @"hello hi @why helo @blow but @name
hello hi @why helo @blow but name@name
@blow but not know how to resolve this";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}