package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[a-zA-Z\u0600-\u06FF,-][\sa-zA-Z\u0600-\u06FF,-]*$`)
var str = `هل بعتم بيتكم في نيويورك`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}