re = /^[a-zA-Z\u0600-\u06FF,-][\sa-zA-Z\u0600-\u06FF,-]*$/
str = 'هل بعتم بيتكم في نيويورك'
# Print the match result
str.match(re) do |match|
puts match.to_s
end