// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\n").unwrap();
let string = "dgxxxxbfbb sjadlasgdlgasli
shadcksavdlcvlas
ashccjhlasvhlcvlasdhc
skjbckjsajc
hjvjcjjhchgcjh
hgcjhcjc hjgchj
ghjxgxng";
let substitution = "\\b";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}