import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/(?<hostname>[^_\\/]+)[\\w\\.]+$";
final String string = "/log/web/output/sat1svmdb1210_0511_kernel.log\n"
+ "/log/web/output/sat2svmdb0100_7689_kernel.log";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}