const regex = /\/(?<hostname>[^_\/]+)[\w\.]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/(?<hostname>[^_\\\/]+)[\\w\\.]+$', 'gm')
const str = `/log/web/output/sat1svmdb1210_0511_kernel.log
/log/web/output/sat2svmdb0100_7689_kernel.log`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}