re = /\/(?<hostname>[^_\/]+)[\w\.]+$/m
str = '/log/web/output/sat1svmdb1210_0511_kernel.log
/log/web/output/sat2svmdb0100_7689_kernel.log'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end