#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[^\/\n]*\.)?(?:google|bing)\.(?:de|com|net)$"
Local $sString = "google.de" & @CRLF & _
"sub.google.de" & @CRLF & _
"www.xxx.google.de" & @CRLF & _
"bing.com" & @CRLF & _
"www.lala.de/bla/?r=www.google.de"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")