import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[^\\/\\n]*\\.)?(?:google|bing)\\.(?:de|com|net)$";
final String string = "google.de\n"
+ "sub.google.de\n"
+ "www.xxx.google.de\n"
+ "bing.com\n"
+ "www.lala.de/bla/?r=www.google.de";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}