const regex = new RegExp('(?m)^=+[ \\t]*(.*?)[^\\S\\r\\n]*=+\\s*(.*(?:\\r?\\n(?!=+.*?=).*)*)', 'gm')
const str = `== Title1 ==
.............
.............
.............
End of Paragraph
===Title2 ===
.............
.............
.............`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}