re = /(?m)^=+[ \t]*(.*?)[^\S\r\n]*=+\s*(.*(?:\r?\n(?!=+.*?=).*)*)/m
str = '== Title1 ==
.............
.............
.............
End of Paragraph
===Title2 ===
.............
.............
.............'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end