$re = '/(?m)^=+[ \t]*(.*?)[^\S\r\n]*=+\s*(.*(?:\r?\n(?!=+.*?=).*)*)/m';
$str = '== Title1 ==
.............
.............
.............
End of Paragraph
===Title2 ===
.............
.............
.............';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);