# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^[\s\S]{0,50})/$1/;t' <<< "Mary had a little lamb,
little lamb, little lamb.
Mary had a little lamb, its fleece was white as snow.
And everywhere that Mary went,
Mary went, Mary went,
and everywhere that Mary went, the lamb was sure to go."