import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^[\\s\\S]{0,50})";
final String string = "Mary had a little lamb,\n"
+ "little lamb, little lamb.\n"
+ "Mary had a little lamb, its fleece was white as snow.\n"
+ "And everywhere that Mary went,\n"
+ "Mary went, Mary went,\n"
+ "and everywhere that Mary went, the lamb was sure to go.";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}