const regex = /(^[\s\S]{0,50})/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^[\\s\\S]{0,50})', '')
const str = `Mary had a little lamb,
little lamb, little lamb.
Mary had a little lamb, its fleece was white as snow.
And everywhere that Mary went,
Mary went, Mary went,
and everywhere that Mary went, the lamb was sure to go.`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);