#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ",+(?=,)|,+(?=\))|(\(),+"
Local $sString = "(,text,,4,text,3,)" & @CRLF & _
"(,,,,text,,4,text,3,,,)"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)