const regex = /,+(?=,)|,+(?=\))|(\(),+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(',+(?=,)|,+(?=\\))|(\\(),+', 'g')
const str = `(,text,,4,text,3,)
(,,,,text,,4,text,3,,,)`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);