re = /,+(?=,)|,+(?=\))|(\(),+/
str = '(,text,,4,text,3,)
(,,,,text,,4,text,3,,,)'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result