$re = '/@if\([^()]*\)(?<!\(null\))\s*(.*?)\s*@end$/m';
$str = '@if(Medellin) City Medellin @end
@if(null) City Medellin @end
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);