re = /@if\([^()]*\)(?<!\(null\))\s*(.*?)\s*@end$/m
str = '@if(Medellin) City Medellin @end
@if(null) City Medellin @end
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end