using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Area=""(?<Area>.*?)""(?=\]|,)";
string input = @"/MyData.csv(MemberCount.sum,Production.sum[Area=""Europe ""Area 1"" (Germany)"",Area=""North America"",Area=""North America [Level A]""])";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}